Erhältst du beim Versuch, eine Versandmeldung an Cdiscount (Octopia) zu senden, eine Fehlermeldung im Log oder tritt ein Problem bei der Übermittlung auf? Häufig liegt dies an der Struktur des Auftrags.
Fehlerbeschreibung
Ein typischer Fehler im Log sieht so aus: Octopia do not support partial fulfillment, please fulfill the main order
Ursache
Die Schnittstelle von Cdiscount Octopia ist technisch nicht für Teillieferungen oder den Versand in mehreren Paketen ausgelegt. Es gelten folgende Einschränkungen:
Kein Partial Fulfillment: Eine Versandmeldung kann nur für einen Auftrag gesendet werden, in dem alle Artikelpositionen enthalten sind.
Keine Multiparcel-Shipments: Cdiscount akzeptiert pro Auftrag zwingend nur eine einzige Paketnummer.
Lösung
Damit deine Versandmeldung erfolgreich an Octopia übertragen wird, musst du deinen Workflow wie folgt anpassen:
Verzichte auf Lieferaufträge: Es ist nicht sinnvoll, mit Lieferaufträgen zu arbeiten, wenn diese den Hauptauftrag splitten. Die Versandmeldung muss aus dem Auftrag heraus erfolgen, der alle Artikelpositionen enthält.
Vollständiger Versand: Alle Artikel eines Auftrags müssen zum exakt gleichen Zeitpunkt versendet werden.
Eine Paketnummer sicherstellen: Achte darauf, dass dem Auftrag nur eine Sendungsnummer zugewiesen ist. Octopia weist weitere Paketnummern technisch ab.
WICHTIG! Hinweis für deine Automatisierung: Überprüfe deine Ereignisaktionen unter Einrichtung » Aufträge » Ereignisaktionen. Stelle sicher, dass die Versandbestätigung an Cdiscount nicht durch den Statuswechsel eines (Teil-)Lieferauftrags ausgelöst wird, sondern immer nur dann, wenn der gesamte Auftrag versandfertig ist.
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